emacs.d

My Emacs configuration files.
git clone git://soucy.cc/emacs.d.git
Log | Files | Refs | README

commit a4cdb711c1118d9fdf276d7dea611bd02f2c49b8
parent ee105cf1acafd79154aa6cb9e5f178cfe4b97ebc
Author: Hugo Soucy <hugo@soucy.cc>
Date:   Mon, 29 Nov 2021 11:14:21 -0500

Rearrange the package archive

Diffstat:
Minit.el | 9++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/init.el b/init.el @@ -4,16 +4,19 @@ ;; ;; SET PACKAGE & USE-PACKAGE ;; +(setq byte-compile-warnings '(cl-functions)) ;; Add Melpa, Marmalade & GNU sources archives for =package.el= (when (>= emacs-major-version 24) (require 'package) (setq package-enable-at-startup nil) - (add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/") t) - (add-to-list 'package-archives '("gnu" . "https://elpa.gnu.org/packages/") t) - (add-to-list 'package-archives '("org" . "http://orgmode.org/elpa/") t) ; Org-mode's repository + (add-to-list 'package-archives '("melpa" . "http://melpa.org/packages/") t) (package-initialize)) +(when (equal emacs-version "27.2") + ;; https://emacs.stackexchange.com/questions/68288/error-retrieving-https-elpa-gnu-org-packages-archive-contents + (setq gnutls-algorithm-priority "NORMAL:-VERS-TLS1.3")) + ;; Install =use-package= if it's not there (unless (package-installed-p 'use-package) (package-refresh-contents)